Unable to Cancel Subscription
Minor incident
Payment and Subscription
2025-07-01 10:46 BST
· 1 hour, 42 minutes
Updates
Resolved
July 1, 2025 · 12:28 BST
The issue was resolved by our provider, and the cancellation is working as expected again.
Issue
July 1, 2025 · 10:46 BST
One of our third-party software systems is experiencing a major outage. As this service is integrated into our cancellation flow, users are unable to cancel the subscription on their own.
If you would like to cancel your subscription in the meantime, please contact our support at [email protected], and we will process the cancellation manually for you.
← Back