Download issues

Minor incident Main site Download
2025-04-16 17:06 BST · 1 day, 1 hour, 2 minutes

Updates

Resolved

The issue has been successfully resolved. Exporting and downloading should be working successfully.
Please note that if you have experienced this issue, you will need to export the project again, and download this newly exported project. Project or files where this issue happened won’t be fixed. A re-export and re-download is needed.

April 17, 2025 · 18:06 BST
Investigating

Our team is in contact with our suppliers to have this issue fixed as soon as possible. We sincerely apologize that resolving this issue is taking longer than we anticipated.

April 17, 2025 · 14:04 BST
Investigating

Our team is still working on resolving the issue. We have contacted the relevant supplier where we believe the issue is occurring. We will post any new updates here.

April 17, 2025 · 10:23 BST
Investigating

Our team is still actively investigating the cause of the issue. We will update here as soon as we have new information.

April 17, 2025 · 08:11 BST
Issue

We have reports that some users are experiencing download issues where files are not downloading, or the downloaded files cannot be played. Our team is looking into the issue, and we will update here once the issue is resolved.

April 16, 2025 · 17:06 BST

← Back