Site and projects aren't loading

Major incident Main site Workspaces
2024-04-16 11:49 BST · 40 minutes

Updates

Resolved

The issue with our site should be resolved now, and projects should show up in your account normally.
Our team is looking into how we can prevent this issue from happening again in the future. We appreciate your understanding regarding this incident.

April 16, 2024 · 12:28 BST
Issue

We are currently experiencing some technical difficulties where the site and projects aren’t loading. Our team is working on resolving this issue as soon as possible. We ask for your patience regarding this issue.

April 16, 2024 · 11:49 BST

← Back