Subscription and account inaccessible
Minor incident
Main site
Subtitle generation
Clean Audio
Login
Workspaces
2023-05-17 16:11 BST
· 24 minutes
Updates
Resolved
May 17, 2023 · 16:34 BST
Our developers have fixed the issue, and the site should be back to normal. If you are still experiencing issues, please contact our support.
Issue
May 17, 2023 · 16:11 BST
Our team is investigating an issue where the subscription is not showing in the account for some users, and some cannot access their account or projects.
We will post further updates here.
← Back