Projects and subscriptions are missing

Minor incident Main site Workspaces
2023-05-12 15:01 BST · 33 minutes

Updates

Resolved

The issue should be fixed now, and all users should have access to their projects and subscription.

May 12, 2023 · 15:34 BST
Issue

Our team is investigating an issue where some users’ subscriptions and projects are not showing up in their accounts.
Right now we are still looking into this issue and we will post updates on this page.

May 12, 2023 · 15:01 BST

← Back