Unable to access the site

Minor incident Main site Subtitle generation Clean Audio Login Workspaces
2023-03-20 10:51 GMT · 20 minutes

Updates

Resolved

Our team has reverted the update that caused this issue. The site should be working normally after a refresh. We will monitor the site to make sure that everything is back up and running normally.

March 20, 2023 · 11:12 GMT
Issue

Our team is investigating an issue that shows some users a ‘Something went wrong’ message when they try to access the site. We will post any new updates on this issue here.

March 20, 2023 · 10:52 GMT

← Back